Freedrum App Android


Hey guys,
I just tried the new Freedrum App (beta) for Android.
I have to say I’m really surprised how well you managed the latency problem. well done!!!
I’m using my old Nexus 5 and it works fine. Also the drift problem seems to be better here than e.g. on the PC with Reaper.

Thank you very much for your good work.


Hello Mitchi! That is great to hear! :slight_smile: Our developers will be proud. It has been a rocky road on Android, but we think we are on the right path now.

Are you able to record a video to show the latency? Would love to see how it is running on a Nexus 5!


Hello Seyran ,

I am using Huawei P8 and i don’t even see the devises in the new application. Is this suppose to work in parallel with sensowere ? Or it should just work.

I’ve tried to fix all the problems with the bluetooth, still doesn’t work.

Best regards,


We have seen issues with Huawei before. The best way to get setup is usually redownloading the app or restarting, but it looks like the device could have a bluetooth issue.

Are you able to connect any other bluetooth devices to your phone?


Hello Seyran ,

Yes no problem with other devices like bluet headphones, car as well . The thing is that with the app sensorware i can see them but they have bad latency so is unusable. So the bluetooth even if is broken, it works on the other application.

I have them for an year now and i wasn’t able to use them properly, so is vey frustrateing but i am still waiting for new android updates. I can’t afford a new ipone even if i would like to start useing them.

Best regards,


Hey Mihai,

It looks like if it is able to connect to Sensorware then it is something to do with the Freedrum app.

Did you allow location services when you first launched the app? We don’t track your information it is just the way that bluetooth is accepted on Android.

Try deleting the app and redownloading it again. See if this helps. Make sure to also reboot your phone to have a fresh start.

Customer Experience Lead


Hello Seyran ,

After reinstalling the app and rebooting the phone, now the app crushes everytime i enter. I’ve had the luck to load it once and it still didn’t show the MIDI devices there.

I don’t want to pressure anyone, cause how i waited a year i can wait more :). I am just trying to signal the errors that i get .

Best regards,