[Guide] How To - Freedrum on Windows 10 with Reaper


#1

There were some requests for a tutorial on how to play with Freedrum on Windows. So here it comes, a step-by-step guide about how you connect Freedrum to your Windows computer and the free DAW software “Reaper” :slight_smile:

Credits also go to Fredrik from Freedrum, HeidisGrandpa and others.

Requirements:

  • Your Freedrum sensors
    (You need to connect the foot sensors to the Sensorware App on iOS or Android to set them as “foot” first)
  • Win 10 recommended (not sure about Win 8.1)
  • An internal or external bluetooth adapter, capable of BLE (bluetooth low energy)

Downloads:

I. Installation:

  1. Download and install the BLE driver and Reaper from above, follow the instructions. Download the zip file of MT Power Drumkit 2. Restart might be necessary.

  2. From the zip copy the two files MT-PowerDrumKit.dll and MT-PowerDrumKit-Content.pdk to your Reaper plugin subfolder. In my case it is located here: C:\Program Files\REAPER (x64)\Plugins

II. Setup:

  1. Connect your Freedrum Sensors. Open the windows options Devices/ Bluetooth and other devices and click the Plus button. Select Bluetooth and connect to your sensors, one after another.

  • They should then appear below under “Other devices” as FD1 xx (depending on the firmware version)
    Their LED might blink blue in changing intervals, it’s fine as long as they are stated as “Connected”…
  1. Start Reaper. Go to Options/ Preferences (or press Ctrl+P). Go to Audio/ MIDI Devices. If the sensors are connected to your device properly, they should appear in the lists. Right click each of the 2 or 4 sensors and click “enable input” - you can also rename them if you like. Click “OK”

  1. Back in Reaper’s main window click on Track/ Insert track (or press Ctrl+T). A new audio track will appear, which you will now configure as your drumkit track.
    First, click on “Input” and choose Input: MIDI/ All MIDI Inputs/ All Channels. Your Freedrum sensors are now the chosen Input devices for this track.

  1. Enable the drum plugin (VST). In your track click on “FX” and select VSTi: MT-PowerDrumkit…. Click on “Skip” in the right lower corner and consider a donation if you like the software!
    If you can’t find the plugin in the list, go back to options again (Ctrl+P) and under Plug-ins/ VST click on “Auto-detect” and/or “Re-scan”. Try 6. again.


  1. Last step: Enable and activate the track. Click on the red “Record” button once to arm and right click on the same button again to activate “Monitor Input”.
    You should now be able to hear the drumsounds coming from your Freedrum!


Sensor Pad Mapping
Assigning any sound at any position
Windows Support
What applications can i use?
[Solved] Search for a device to connect to
[Solved] Latency on Windows 10 is gone!
[Solved] How can I use pedals with MacOS?
[Solved] Hi, I'm playing thru a samsung
#2

Last but not least some tips, if you are facing latency issues.

First of all: Try restarting your computer, maybe even several times :smile:

Then there is something about buffer size and different audio modes or systems, that affect the audio latency in Reaper. What I’m telling now, is not based on very deep knowledge on this matter, I just tried and played a bit with the parameters…

There is an info in the right upper corner of Reaper, looking like this:
[48kHz 24bit WAV : 2/2ch 144spls ~ 10/25 ms WASAPI]

Click on it and you will see the Audio Device options. You can choose from different audio systems and edit some parameters. What worked best for me and reduced the latency to about 10ms is the following:

Audio system: WASAPI (Windows 7/8/10/Vista)

Block size: 128 samples

There are more options, sometimes coming with different results regarding the quality and loudness of sound etc. Might be different from device to device, so feel free to try and give us some feedback on this :slight_smile:

One thing if your machine is powerful enough: You can create multiple tracks and also have one track for each single Freedrum sensor. Gives you some freedom in choosing your soundkits, but results in higher latency (at least I was unable to practically use it this way).

Enjoy !


Freedrum with NI Maschine 2?
Show Us How You Use Freedrum
#3

Amazing!

Thanks for that. Do you got a sound-sample of the suit by using it with Freedrum?

I want to know if it’s worth.


#4

Here you go. Use headphones for best sound :wink:

Just a short recording, nothing special. Not perfectly played as it’s tough to deal with the 10ms latency in faster parts, especially in terms of double bass.

Keep in mind that you can basically make your own mix of the drumset sounds!


Show Us How You Use Freedrum
#5

Sounds pretty nice, thanks.

Do you switched the crash cymbal or is it default?


#6

There are two different crash cymbals, left and right. This one in the recording is the left crash, the other is a bit more similar to the china…

Soundwise this plugin is pretty good actually, with a lot of variety in terms of velocity and so on. But there are other VSTs (free and paid ones), you can try. Reaper as a basis is perfectly fine :slight_smile:


#7

Ah, Nice. I will try and give a feedback right here :wink:


#8

thanks for the tutorial, very complete. running at first


#9

Just ordered my Bluetooth dongle for my Winows 10-Client.

I will respond the results as soon as I run the first Tests.


#10

Hi Alex, you saved my life! Freedrum was surprise gift for my son but he is a Android guy.
We’ve got the 4 sensors working in W10/Reaper on a veeery old laptop but with new usb bluetooth adapter (GBU521). Works fine.
Only problem is that not all drums/cymbals are in the correct place in ‘space’.
Any one knows how to edit the mapping?
The drum plugin can load PDKmap files for various drum kits. Which drumkits to use for Freedrum? Or how to create/edit one?
Thanks!


#11

What do you mean exactly, which drums are not correctly positioned?
Did you have a look at the tutorials regarding the correct angles to play?

One thing, if you still have these problems: Open the MT Power Drumkit 2 window (click on the FX button of the track) -> go to Settings and there you see the MIDI mapping.

To manually change, just click the drum/cymbal and then hit with your Freedrum whereever you want to have this particular element.

Make sure that there are no “unmapped” or “double mapped” elements (they get marked red). You can change some unwanted ones to any random MIDI note with your mouse.

Hope you and your son get this to work :slight_smile:


#12

Alex, Thank you! Got it all set up through this tutorial.

Even after calibrating through the angular sheet, I wasn’t able to get the foot sensor to work as kick. It was reacting as floor toms?! I tried mapping but couldn’t figure out how to map!


#13

You’re welcome!

That sounds strange. Did you connect to Sensorware on any phone (android or iOS) before and set the two particular sensors to “foot”?

That’s something I could add to the tutorial. The Sensorware connection is needed beforehand :slight_smile:


#14

YES! I did. I need to write on the sensors so I don’t confuse them.


#15

#16

Hi,
I have solved by inserting 2 PowerDrumkit, and 4 midi fictitious virtual tools.
to each fictitious devices I have connected a sensor and then using the “route” (the button next to the instrument name) I redirected the “hands” to a PowerDrumkit station and the “foots” to the other.

So I configured the two stations differently.


#17

Hi Alex, Thanks again! We experimented first with the handsensors which were connected to sensorware before. Then took the footsensors out of the box and forgot about the settings. Will try again tonight.


#18

Hi. I have followed your step by step tutorial on my asus with windows 8.1 and it works as you said. However i was wondering whether it is possible to reduce latency to less than 10m/s?


#19

Good to hear, that even Win 8.1 doesn’t make any problems, thanks! :slight_smile:

In the device settings its saying, that I should have around 2ms latency (depending on the buffer and bitrate I guess), but practically it always ends with about 10ms when playing…

It might the, that the Bluetooth adapter is the crucial part in this matter. You can try external ones or wait til other users do and give feedback :wink:


#20

I’ve tried this Dongle (as I already reported @Alex_Incensus per private message):

The lag isn’t any better with it, but for a Universal Audio Driver might help. http://www.asio4all.de/ is recommended in several Reaper forums. Please follow the Developers introductions to provide the best results.

If this won’t help, follow this Guy:
https://forum.cockos.com/showthread.php?t=48884