[Guide] How To - Freedrum on Windows 10 with Reaper


#21

Thanks so much for this! I was able to successfully connect to my PC… however, I’m still having latency issues.

After changing the audio device to WASAPI, I get the message “WASAPI error: could not find input device” so I tried using ASIO4ALL instead. After tweaking some settings, I was able to get the latency at 10ms… but still experiencing some issues for some reason.

Anybody having a similar problem with WASAPI?


#22

Hi I’m having a problem, I can not connect the sensors through the bluetooth to any of my computers. Apologies for my english


#23

Hi,

here is my experience:

MSI GE620 notebook - built in blutooth not supporting LE
Win10 Pro, build 15063

ASUS Blutooth 4.0 dongle
Superior Drummer 2
Toontrack Solo
Asio4all, 64samples buffer

= GREAT latency :slight_smile: and experience.

How to:

  • install Asio4all
  • disable built-in blutooth
  • install ASUS dongle
  • install KORG driver
  • connect Freedrum (set foot sensor to foot in Android/iOS app first)
  • open Toontrack solo
  • load SD2
  • Options/MIDI device, select all
    -Options/Audio device, select asio -> asio4all
  • Options/Audio/Latency -> set to lowest value where you do not get any cracks/distortion of sound

PLAY!!

Disable all unnecessary apps, like antivirus, firewalls, internet adapter, wifi adapter. Set your PC to Performance mode in Power settings in order to get the lowest latency possible.


#24

@Brandon_Tran, what kind of issues do you have? Just some lag, a noticeable latency even though it says “10 ms”?
Here is my configuration of ASIO (with ASIO4ALL), that brings the best result (Reaper is saying 4,6ms):

About the WASAPI error message I don’t have an idea, unfortunately. If you followed the steps above (connected properly to Windows, set them as enabled MIDI devices in Reaper …), it should be fine :confused:

But try a bit more around with ASIO, for me that’s the better option.

@braianoi, does any of your computers have Bluetooth Low Energy? Did you follow the steps above completely and all requirements are fulfilled? Can’t tell what the problem might be at this point :smiley:

@jamadza, thanks for your feedback! I changed the buffer in ASIO to the minimal 64 samples and its coming along nicely :slight_smile: I didn’t think it would work with less than 128 (that was the lowest before ASIO4ALL was installed), but it actually does.


#25

Hi Alex, thanks for the tutorial for setting up a Win app with freedrum. I follow up and it´s working rigth now, but with a strange issue: the sensors lost he configuration when change the pad area an play a diferent sound, for example when I am playing the cymbal and sudenly change to the snare, the sound I get is the crash. It is necesary to reset the sensor, but this happend very frequently. I cant play as you show on your audio sample, so smooth and exact response at high speed. Any suggestion?


#26

@mdovali
I don’t know how much advanced you are in playing, especially with Freedrum. It requires quite some time of practicing til it works well!

It actually sounds like you’re not hitting the “pads” 100% correctly (Reaper is not very kind in this matter ;)) - try following the tutorials the FD team is providing, especially in this thread:

Oh and one thing: If this happens with all the sensors equally, you can be quite sure that it’s not “their fault” :slight_smile:


#27

Thanks for your reply. Certantly I am a begginer drummer, but the problem I try to explain is not related to hit the pads out of the correponding hit area. Another explanation of the problem could clarify mi issue.

Before I start playing, I hold the sticks in front of me (without any horizontal angle), in horizontal position (over the snare virtual pad) and clik the sensors button. The led turns on blue and when I release the button the led turnn on white/blue. I verify the 6 virtual areas of the kit (I disabled the open Hi Hat to simplify) and all of them responds correctly, when I turn to my rigth (according with the tutorial) and hit the floor tom and the cymbal (with both sticks), the leds turns on pink and respond correctly. When I turn to my left and hit the hi hat and the crash, the leds turns on green and works correctly. Then I begin to play a swing rythm and I play a four stroke fill over the snare and return to the swing rythm. At the second or third fill sequence the sensors lost the configuration. The rigth hand stick thats plays the cymbal, when I play the snare in the fill, sounds as a floor tom or cymbal, the leds are turned on pink instead of white/blue. When I stop the play and put the sticks in the initial position in fron of me, over the snare, the left hand is ok in white/blue but the rigth hand is in pink.

Any idea of what could be happend?


#28

OK sorry, very often it is a very simple reason, why people experience this kind of drifting issue :slight_smile:

Then I’m out, unfortunately! There are several topics here about issues like this and I think, the Devs are the better ones to solve it.
I can just repeat their solutions and tell how it works in my case :wink:


#29

If the right hand stick is purple in the middle it means that drum kit turned to the left, this happens if you’re playing in the “left edge” of some area (green or blue or purple), so it started to adjust itself, which shifted everything to the left. Try to play more to the right with your right hand and see if it helps.

Also tried to use my Windows laptop + built-in BT adapter + KORG driver + Reaper + Superior Drummer 2 + ASIO4all. Managed to get latency about 7ms, but I have another problem. When I play let’s say snare drum with one stick only, and with a slow tempo, the latency and feedback is perfectly fine. But when I start playing with 2 sticks very fast, the sounds coming in a sequence, with a staggered delay (throttled). Which feels more like a bandwidth issue. Could it be related to built-in BT adapter being just bad? Because all the drivers work fine, and as I mentioned the delay of a single sound is very low (7ms). Should I try USB Bluetooth dongle instead maybe?

(UPDATE): tried unknown brand USB BT 4.0 dongle that I’ve found in the office and it works perfectly fine! So the problem was indeed because of built-in Bluetooth in my ASUS ROG 551JW.


#30

Have you checked if the manufacturer of your laptop offers a newer driver?

Sometimes a current software helps with old components - I had this for example with a Bluetooth conference phone once, after installing the current software it ran again as expected.


#31

Hi, yes, I’ve downloaded the latest driver and tried that as well, didn’t help.
So I’m happy now with the USB BT dongle :slight_smile:


#32

I bought the above mentioned dongle and I am very satisfied with it.

On windows 10 I get 2-3ms and on OS X even 1-2ms. iOS runs as licked anyway.


#34

Thanks for the tutorial, Alex!

How do you configure foot sensors to trigger the bass drum in Reaper? But without the Sensorware, because I can’t run it (don’t have android 6).

Rarder44, I see you used two tracks with MT-PowerDrumKit plug-ins, fictitious midi devices (?) and routing to get the bass drum. But I can’t figure out, how to do it :-). Beginner, step-by-step tutorial would help :-).

Thanks


#35

@jaku, hm that’s a tricky question.
No way to get access to a compatible Android or iPhone for setting the sensors up?
Maybe the beta for Android works?

Edit: Surely you can also add a 2nd track with the same plugin (just repeat the steps in the tutorial) and configure the input differently.
Instead of ‘MIDI input all’ you should be able to select single MIDI inputs - I’m not quite sure however, if you can separate the 4 sensors into 2 input “groups” …


#36

Thanks for the tip :-). I used colleague’s iPhone and configured the foot sensors successfully.


#37

Wow …
Thx a lot for this Tutorial … it saved my freedrums for getting a life in a box, so far :slight_smile:

It Worked with:
Windows 10 (newest Version)
The Kork BT Driver (that was the missing link)
Reaper (newest Version)
and superior Drummer 2.0 with the Metal Kit.

The only think to do now, is learning the playing style of freedrums … i hit often the wrong pad … :disappointed_relieved:

Thx

Michael


#38

@Wallil, glad to be of service ;D

It doesn’t take too much time to get used to the playing style. Practice, practice and you’ll master it soon enough :slight_smile:
Have fun!


#39

sad to say …
today it didn´t work, i didn´t get the footsensors connected (yes set as foot in the ios app).
And now reaper only knows 1 device … not two or four (yesterday i used only the sticks and see 2 Midi devices).

I restarted a serval times … reinstall all software … no effekt.

:disappointed_relieved:

Walli


#40

No need for reinstalling software I’d say.
Try disconnecting the sensors from every device and also take care not to have multiple Bluetooth devices turned on at the same time (like your phone + computer).

Connect them one after another to your computer only again. If it’s not working, try hard resetting the sensors or force an update of the firmware (pressing the button til it turns yellow and start sensorware on your phone - apply the update).

Disconnect them from your phone, maybe even turn them off and connect them to your computer only after turning off your phones Bluetooth.


#41

Hello Alex,

I’m new to this, and i don’t know how this works. Bought an Bluetooth Device and connected the sensors, but in Reper they are not found. Can you please help ?

Thank you,
Mihai