[Guide] How To - Freedrum on Windows 10 with Reaper


#42

Hi,

Might be the case when you open Reaper before connecting the sensors. Just try to first connect them (make sure they appear in the list of Windows Bluetooth devices) and only then open Reaper.


#43

That is exactly what i’ve tried but it is not working. More information’s if you have.

Thank you,
Mihai


#44

First of all i would like to thank you for such an awesome tutorial, this definitely made me more thankful for buying freedrums. honestly the sounds that the drums were giving from the app was nothing compared to the one in reaper. I followed each step of your tutorial. I was able to get the drums sounding superbly with no latency issues whatsoever. However i notice that one of my drum parts were missing when playing with my freedrums. i have 4 sensors, however i notice that i am missing a hi tom when playing. i tried to change the settings in the plugin as you suggested. However, i could not figure it out. could you please help me in locating my missing hi tom? its quiet annoying to play a full set of drum without a hi tom… cant practice my fill ins :disappointed_relieved:

thank you,


#45

@TheCookie
Stil having this issue? I’m not sure what might be the problem. When properly connected to Windows the sensor’s LED should be pulsing blue or green or so… And be listed in the ‘connected Bluetooth devices’ panel.
If this is the case, Reaper should detect them in the MIDI devices option automatically and you have to enable them.
If not… Hm, maybe try updating the firmware, resetting the connection…

@articpengi
So if I get you right, your High Tom is not working at all?
That’s strange, I usually only had this problem in GarageBand with a few DrumKits… Anyways, maybe try updating the sensor firmware (maybe even use the Sensorware beta for getting the latest beta version?).
But is there a signal coming when hitting where the Tom should be located?
You can either see this in Sensorware or in the plugin settings: Click on the High Tom and hit the area you want to assign - you should see that something happens on the screen (red marking).

You need to get rid of any red markings before applying the settings, see one of my earlier posts…

If you’re still not hearing the Tom sound, its maybe the plugin. Can you hear it when clicking the virtual High Tom in the plugin window with your mouse?


#46

Hello Alex .

The leds are working fine. The problem is that i’ve made there updates on an android phone(Huawei P8/known to have problems). The version is v6 and the lede as i’ve connected to the computer are blue, but they are not viaible in Reaper.

Don’t really know what to do. Maybe i will try with an Iphone at least to update the MIDI devices, maybe after they will work.

If you find anymore informations, please contact me, i will be very gratefull.

Thank you,
Mihai


#47

thanks for replying fast. I tried to edit some of the mapping for the freedrum. However, i still could not edit the hi tom. everything else works fine such as the floor tom and the mid tom. however i could not get the hi tom to work? is that just how freedrum works? you cant have more than 2 toms? cause i saw other videos of people playing freedrums where the 2 toms the mid and the hi toms were connected to one single tom?.

i also left my set up if you could help me spot a problem

i also notice that my ride cymbal can only be used by my right stick, is that normal?


#48

No and no, that’s not how Freedrum just works and that’s not normal :sweat_smile:

You should be able to have every single Drum as a Tom, High or Mid or Low, doesn’t matter. Freedrum only gives out MIDI signals and they are completely editable.

But I think I see the issue, a misunderstanding…

What do you mean by “two toms connected to one”? In the current stable version of the firmware there are only 6 hitzones, of which by standard only two are a Tom. A High and a Low…
If you want to have more hitzones (as seen in my videos), you need to download the Sensorware Beta on Android.
Then you can configure the Sensors themselves, having more hitzones and giving out a particular MIDI note you choose.

You can however have more Toms right now as well. But then you lose other things such a the crash cymbal.
The LEDs are your indicator on how many zones you have, their colour changes when hovering over the (normally 3, in the Beta 5) horizontal areas.


#49

Hi there,

I have difficulties with detecting the MT-PowerDrumkit plugin. It does not show on the list. I have tried restarting my computer, auto detect and re-scanning. All has failed. Anyone having similar problem and did mange to solve it?


#50
  • did you unzip the plugin in a folder or did you keeped the zip version (on my computer, it’s unzipped) ?
  • did you add the folder to your plugins directory list before rescanning ? (for example for me, C:\Program Files\REAPER (x64)\newplugs)
  • when you insert FX and have plugin list, by default, Reaper ouputs only theirs (Cockos part), you should click on the left on “VSTi” to display VST instrument list instead of all reaper plugins. Or click “All plugins” and use the search bar at the bottom of the plugin list windows ?

I don’t see what could gone wrong, maybe you’ll have more help on the reaper forum (lots of users, really !)


#51

@Alex_Incensus I’m having the same problem, I use the Raper + MTpowerdrumkit2 and I can not get the foot sensors to enter as a kick drum, even if I’m already enabled in Sensoware to walk in, it comes as a normal hand sensor. So I have some doubts: 1) after configuring the sensors in Sensoware, I need to leave it connected to the android? 2) after configuring the sensors in Sensoware and entering them in RAPER do I have to change the map? Because I try to change the map but the area I put for the kick drum is always being used and is not allowed to use it again. What do I do?

Thank you very much for the availability :slight_smile: Thank you


#52

@jsj23
It could be that your Android device doesn’t properly connect to your sensors and so the app’s settings (changing to foot sensors) don’t reach your sensors.

This might be… If the phone you’re using isn’t fully compatible (some Bluetooth issue).

Try using a different phone from a friend or family member, maybe even an iPhone as they work pretty seamlessly.


#53

I’ll try. But my android is 6.0, was not it to work?

Grateful!


#54

Not only the android version matters, the device itself does, too.
And sometimes these things are like magic, both in a negative and positive way :wink:

Try this and tell us if it worked.


#55

Exactly the same problem here. I copied the MT-PowerDrumkit files into the Plugin folder of Reaper, restarted, auto-scanned, refreshed, drank a coffee, closed Reaper, started Reaper again - nothing. The files do not display in the list. Very frustrating!


#56

Thats strange.

But please keep in mind that Reaper and MT Power Drumkit are not related to Freedrum in any way. Maybe you check out what might be the problem with one of these two.

Actually its pretty simple to use Plugins in (any DAW/) Reaper. Still there could be a problem of some kind, which I am not sure about :confused:


#57

I’m having huge issues installing the Korg drivers. I have a surface 3 ble compatible running the latest fall creators update and everytime I attempt to install the drivers I get a message saying: “This installation package could not be opened. verify the package exists and that you can access it, or contact the application vendor to verify that this is a valid windows installer package” Anyone have any ideas? Or an alternate MIDI BLE driver?


#58

Just wanna say “thank you”. Works like a charm with your latency adjustments.


#59

Hello, I haven’t got my sensors yet, but I know a bit about working with MIDI. There is an overlooked setting that might be causing some issues. This is the quantization setting. For all you super fast players, you want to have your quantization set to the highest level you can. In Reaper this would be 1/128th notes. Hope this helps some of you out. :slight_smile: Only a week till my kit arrives!! YaY!!


#60

I have a problem with my Freedrum on windows. It was working normal, I turned on the sensors and they were already paired with my pc and when I opened the Reaper they already appeared on the MIDI devices. However, they now no longer appear. I’ve removed and reconnected bluetooth, rebooted and nothing. Does anyone have a solution? Thank you in advance for the community. :slight_smile:

P.S .: I’m using Reaper + MT Power DrumKit


#61

Unfortunately I’ve got the exact same problem now myself.

Sensors won’t properly connect to Windows (they are shown as connected but the LEDs pulse blue) and therefore are not recognized by Reaper.
Maybe there was something in a Windows update…? I will see if I find a solution :confused:

Edit: This shows the issue…