How to update the firmware


If you don’t know how to update the firmware on your sensors. Please read this guide.


Hi, I got this message “There was a timeout when starting the update.” when trying to update one of the sensors, and now it’s stuck on red without updating. What do I do?


Hold the button about 10 seconds untill it restarts. If it turns yellow, repeat the pressing. If it’s still red and you can’t reboot it. Fire up sensorware and it will ask you to update. Press yes and after 90 seconds it should be ok.

[HowTo] Solving Connection Issues on MacOS

Thank you! That helped it get out of red mode…

However I’m still unable to update that sensor without it timing out every time. Is there possibly a fix for this?
Note: the other sensor updated just fine.


The new sensorware update has actually solved this issue. Both sensors are now up to date. Thank you for the help


Hi, I managed to update one sensor (it writes fd1 v5) and the three others stayed at v3. How do I update the rest on windows?
Btw works fantastically with asio driver almost 7ms latency…


You can only update the Sensors through an iOS or Android device.


Hi guys, I’m trying to update my sensore with sensorware on android device.

My sensors is on with yellow led and sensorewire blocked on starting DFU, I can’t update/use my sensore…

How can I resolve this problem?


Hi, I am also trying to update the firmware on my sensors and I keep getting a remote DFU Invalid CRC error, and I can’t use one of my sensors.

What should I do?


Please mail Well help you from there :slight_smile:


Hi, I am trying to update the firmware using iOS 11 (v1.3, iPhone SE). I am getting two types of errors:

  1. The Sensorware app crashes when I try to update the firmware on the sensors

    • I tried to work around this by holding the sensor for about 10 seconds to get into update mode (green / yellow light glows). However, the message I get then displays a “There was time out when starting the update”. This brings me to the second issue
  2. “There was a time out when starting the update”. I managed to follow all the steps suggested in this thread to get rid of this issue. However, the issue still persists no matter how many times I repeat it.

Please let me know if there’s a fix for this problem


Hello Aditya,

Can you please email me directly on to better assist you?

Thank you.


facing the same issue here… cant update through sensorware. app crashes before saying “timeout detected”…


Has there been any updates for android?



Have you tried deleting the app and reinstalling it? Also, make sure to reset your device by powering it down.
What device are you using with Sensorware?


We have an Android update coming soon we are still in testing right now.