No sensors detected for the new One UI 2 - Android 10


#1

Dear Freedrum Team,
after updating a Samsung smartphone Galaxy J6 to the last One UI 2 for Android 10 (from March 2020), no sensor is detected neither by Freedrum app nor by Sensorware app.

Some procedures tried …
Removed cache from Bluetooth
Reinstalled both apps
Reset app preferences

I would really appreciate your prompt support.

Best Regards,
Berria


#2

Hello Berria,

We are not aware of the One UI 2. Is this its own operating system outside of Android?

We are aware that sometimes the locations services not being allowed when installing the apps can cause an issue with sensors not being displayed to connect.

Also, you mentioned that you restarted your devices and cleared the cache from Bluetooth. Do you have other bluetooth devices connected? It could be a limit on the amount of devices connected or stored on your device.


#3

Hallo Seyran,
One UI 2 is a new evolution for Android 10 …

No more Bluetooth devices around or connected.

Thanks in advance !!
Regards,
Berria


#4

We can assist you with this. It could be a number of things, but we can provide you the steps to fix this.

Please start off by deleting both the Freedrum and the Sensorware app from your device.

  1. Go into your Bluetooth settings on your device and delete any sensors information you can see. We do this to have a fresh start.
  2. Reboot your device. Not just pressing the power button but powering down the phone completely. This helps with making sure the devices do not get cached in the Bluetooth settings.
  3. Turn on your device and download Sensorware.
  4. After opening Sensorware it will ask you for your location services. This is key to using Bluetooth in the app and connecting. We do NOT track you or using your location.
  5. Once this is done the sensor that is turned on should connect to the app. If not, then follow the next step.
  6. Hold down the sensor until it turns yellow. This puts it in update mode. If the app doesn’t recognize the sensor then restart it.
  7. Once you restart it should detect the sensor is in update mode and attempt to update it.

Let us know if you are still having issues after setting this up.


#5

Hi Seyran,
thanks so much.

The app has the rights to use the location services … but still no sensor is recognized.

Nevertheless … good news !! They are detected when the GPS is on !! (and with the previous version there was not a need).
Hoping that this clue can help your team to solve the issue.

BR,
Berria