[Ongoing] Freedrum app and Sensorware problems


#1

The sensorware app keeps crashing every time I try to update my drumsticks and there isn’t a way to update in the freedrum app. How do I fix this to update my drumsticks?


#2

Yup. Same problem for me. I have an iohone 6 on latest iOS firmware and an iPhone 6plus on iOS 11.1.2

Free drums are updated to v7 already but app crashes on BOTH phones! So it’s clearly an app issue

Not good :frowning:


#3

Same problem. I had v7, + I’ve set 10 zones on sticks sensors via Android beta sensorware, but now 3 of my sensors are not playing at all, they’re connecting, then blinking with red, then do not respond until I hard-reboot them with holding the button for 10 sec. Only one sensor “survived”, but lost it’s 10 zones settings, it got back to 6 zones…Still not able to try the new app, and even cannot play with my usual setup now, because the sensors are not responsive…Even tried to update from DFU mode, it starts update but then sensor blinks red and goes to sleep again…Great…


#4

Mine connect then disconnect on their own, updating them closes out the app. I’m glad that I’m not the only one it’s happening too but it sucks that it’s not working for us. Hopefully they could fix it.


#5

I also don’t really understand what could be done to a sensor so that it doesn’t update even in DFU mode now…It happened exactly after I connected them to this new Freedrum app (that by the way worked fine in beta testng). Is there any non backward compatible changes? Or how can this happen then the device is not updatable in DFU?

@Fredrik, @Seyran I hope you guys looking into this issue? :slight_smile: it’s quite a game breaker…
If you need any help in debugging, please let me know, maybe I can provide more details or make a video of how to reproduce the problem.


#6

Hi, i’ll look into it as soon as possible! :slight_smile:


#7

So is there any way to fix yet???


#8

Still nothing? the new app fucked me up as well…


#9

I really hope it gets fixed soon bc I gotta practice my drums for my band


#10

Hi, nope, I guess someone from the team will answer here if they have a fix. That’s unfortunate…Such an anticipated app, a bit disappointing.

I’ve managed to Update my sensors in DFU mode with iOS Sensorware app on another iPhone btw. But still, when connected to Freedrum app, only the first sensor only the first time was producing sounds. As soon as I’ve connected second one, it got immediately disconnected, and then even the first one stopped working again…


#11

I have no idea why I tried to use the new app, its not like the new app was giving me anything new.
On pc i was having a blast besides the mapping problem, I just hope they fix it.
Cause for now i cant play FDrums xD and i used to play every single F*** day.


#12

yeah I feel your pain. Same for me. At least I’ve managed to recover sensors to v7 from iOS Sensorware in DFU (yellow LED) mode. So now I can play with Reaper+PowerDrumkit on my Macbook. Will never connect to Freedrum App until I know 100% that it doesn’t brake anything. My 10 zones setup is gone, Android beta.13 is gone from Google Play beta store, Android beta.11 doesn’t connect to the sensors. So it’s a backdraft obviously…Now I’m stuck with the boring 6 zones without my 2 crash, china, splash, 3 toms setup. Feels bad man :slight_smile:


#13

Explain DFU (yellow LED) mode please, I dont mind going back to the same boring set up… I just want it to work so i can play…

The only thing that i want as upgrade is ReMapping back!
Thanks @Asgvard


#14

DFU mode can be activated by turning-on the sensor by holding the button until it turns on with a Yellow light.
So:

  1. Turn off
  2. Hold the button for ~5 sec
  3. Yellow light appears
  4. iOS Sensorware app 1.4 should say smth like “sensor in Update mode detected, do you want to update it?”.
  5. Press Update. Worked for me w/o crashes.

#15

Updated the Freedrum App today, works fine now! Thanks for the update.
Though still not able to setup 10 zones with Android Sensorware beta, but I hope the custom pad settings will be available soon in the new app. Looking forward to it, since now even though it works, I would be much happier to have the setup I already had before, otherwise it’s kind of a downgrade in a sense that by getting 3D kit and cool sound samples, I’ve lost 10 zones :slight_smile:
But anyway, good job!


#16

Hey @Asgvard.
I’m not ignoring you, I’ve just been very busy.
When we are back from namm I will try to help you and sort out the problems you have with the zones! :slight_smile:


#17

Hi there,
I got a new problem,
today with Freedrum app,both iPad and MAc, the top tom don’t work.

I’ve tried to connect and disconnect 3-4 times the sensor but nothing append.

Can you help me?

Bye!
Andrea


#18

Had the same, go to Sensors, and set the stick sensor as Foot and then Back to normal. This will reset the MIDI notes on it. Perhaps they changed MIDI note on the top tom :slight_smile:

@Fredrik no worries :slight_smile: I actually didn’t expected even this update while you guys are at namm 2018, I’m watching your instagram :smiley: good luck there!


#19

Hey, I’ve been having problems with the Sensorware app as well as the Freedrum App.
After the Freedrum App was introduced I downloaded it and used it. When I had turned the sensors off the there was a problem that when I wanted to use them again my phone recongnizes the sensors but does not recognize what firmware they run as well as my hits. This is just particular for my iPhone 8. I used an iPhone 7 and downloaded sensorware and it works perfectly. All sensors are updated to v7. I thought the sensors had forgotten what firmware they ran so when I tried to update the sensors on my iPhone 8, and 7 the sensorware app would crash. I haven’t been able to play my freedrums and I have deleted the app multiple times in hopes that maybe it had something to do with the apps cache. I don’t know if I’m the only one having this problem. My sensors and sensorware worked fine before I installed the Freedrum App. I used GarageBand and there was no problems. I don’t even bother to try working with the Freedrum app if I can’t even get sensorware working.
I have tried multiple things like forcing my sensors into update mode but the sensor times out, I was able to update from my android really easy, but when connecting back to my iPhone 8 the problem is still there.


#20

Hi,
Ok, yesterday night I’ve got another problem:
Iphone 5s crash with freedrum app, it don’t start.

just to know it…

Good works!
Andrea