[Solved] Latency on Windows 10 is gone!


#1

I updated my sensor’s firmware with the android beta to Freedrum D60 a couple days a go, now i plug and play on pc without tweaking Asio4all and I get even better results than my Iphone 6.
On my phone my sensors go nuts when i do (fills) with multiple midi sign at the same time, that doesn’t happen on pc anymore even playing kinda messy.
The only down side is that i lost the ability to Map my sensors so all my Crash send the same MIDI Signal for example doesnt matter how i map on MTDrumkit.

I’m happy to answer any question about my setup if anyone wonders.


#2

I’m interested ! What did you do exactly, only a sensor firmware update ? No action on android phone or your windows computer ?
Regards


#3

I Basically grabbed a friend’s phone that had the Sensorware Beta then i updated the firmware, and thats it for the sensor’s.
Then I plugged on me pc and now the sensors call “Freedrum”, i followed the tutorial [Guide] How To - Freedrum on Windows 10 with Reaper without Tweaking on buffer sampels size, i still play on 512 samples the sound is really amazing and theres no drawback.

Specs_ My laptop is a Razer Blade 15’’ 2017

Intel® Core™ i7-7700HQ Quad-Core Processor with Hyper-Threading 2.8GHz / 3.8GHz (Base/Turbo)
16GB dual-channel onboard memory (DDR4, 2400MHz)


#4

Thanks for all the details ! I’ll probably just wait for answers to this thread before trying the beta + firmware update : [Solved] Android Beta on iOS/macOS? Downgrade possible?


#5

Latency disappeared on my PC today too! But all I did was install Windows 10 Fall Creators Update.

I had everything set up according to Reaper guide before the update, but still couldn’t get rid of the latency. So I’ve shelved the freedrum :disappointed_relieved:. Today I’ve decided to give it another try and the latency is gone.


#6

Good to hear.

Any workaround to update through iOS ? And how to verify which firmware is currently installed on the sensors?

I am using FL through MTPowerDrumkit and getting slight delay… more noticeable when recording midi. However, I would like to mention I am using focusrite solo interface instead of Asio4all…


#7

Stop using FL ASAP i think he was helping on the delay, with reaper is awesome enough… but i recommend try Ableton live.

about the firmeware update I`ll try right now and let u know…


#8

Well, I thought I would be able to use drumaxx and FLdrumpad using freedrum.

On my iOS paired devices I see fd V7 so, I assume its v7 for my kit.

I will give reaper a try… can you suggest some plugins other than MTPowerdrumkit? and how to make it more responsive. I am using focusrite audio interface so limited choice of tweaking through ASIO panel unlike Asio4all.


#9

My sensors says FD1 60 not V7 and i tried everything and it doesn’t update!!
If the devs give us the ability to map our sensors like once was on Android BETA i would recommend EZDrummer 2.
About ASIO im not an expert and i hate that program xD


#10

haha… unfortunately thats the best response I got from a windows build… :stuck_out_tongue: