[Solved] Will the second foot sensor ever be a hi-hat pedal?


Im sure this has come accross some peoples minds. But i’m surpised it has not been asked yet.

I myself dont play using two bass pedals. I was curious if the second foot sensor will ever have the option to become a hi-hat open/close pedal. Just like in a typical ‘normal’ drum setup?

In really hope so. As other than this, the freedrums are excellent, but I want to have some use for the 4th sensor I own. At the minute I just use the two stick sensors and ‘one’ bass pedal sensor.

Please could you advise. I’d imagine with how far youv’e come, it can’t be that hard to do, right???

Anyone else with me on this??



Yes. I think the same.
There should be a foot control for the hand sensor when the hihat is played.
Also there should be the partly open (or closed) position and sound.
And the sound of the open hihat in the sensorware app does not fit with the closed sound (in my ears).

Foot sensor of left foot
Is there any way to set Open Hi-hat to lifting the foot sensor?

Yup guys, it’s in the pipeline for us. This is not possible in Garageband since the sensors don’t talk to each other and hence it’s impossible for the hand sensor to know that it’s supposed to send “open hi-hat” notes when the foot pedal is open. But for sure we’ll soon do this in the Sensorware drum-synth which we develop ourselves.


The left foot pedal works like a hi-hat when you turn your left foot out left.
If you want to use it as a hi-hat in a relaxed straight foreward position, just turn your left foot inwards and press the button on it once to calibrate. When you turn it back straight, it will recognize this as the hi-hat position.
To play an open hi-hat, just twist the the right hand stick in its hi-hat position towards yourself (sensor switch pointing towards you rather than up).
All the best


Hi August,
Your explanation made it clear to me why there is no “normal” hi-hat functionality.
The perspective of a Freedrum synth sounds very promising.
If I may wish something: give it adjustable volume/sensitivity/velocity settings (I am not sure what the correct technical term is). At the moment you need rather strong motions of your feet to let it sound loud enough.


That problem should be resolved like this: Bass drum velocity/loudness


There are drum machines that support hi-hat pressure. E.g.

It looks like MIDI CC #4 (foot pedal) is used for the hi-hat, and depending on its value, a drum machine can choose the current hi-hat sample. Often, a pressure range can be mapped to a hi-hat note to play.

Hope the Freedrum implementation will be compatible with this (so I can do this in Hydrogen too). Great to hear it’s on the radar!


Thanks for the links! Yeah, definitely a feature to come soon. We’re using our own SFZ soundfond player, and there’s actually support in the the SFZ format for having foot pedal, see locc# and hicc# here http://drealm.info/sfz/plj-sfz.xhtml



Yes, this sounds a lot better, more balanced. Thank you for implementing this feature!


another option that might work to implement a “real” hihat pedal on ios.
sensorware app could act as a stateful midi mapper…
I doubt that this would work for ios garageband, as the drum app must be able to configure the input midi channel, e.g. drumjam supports this. This will add an extra delay but on ios this doesn’t seem to be a problem.

It would work like this:
a) take events from input channel
b) if hihat pedal is pressed/release then store that state internally in the app
c) if hihat gets hit, then evaluate internal hihat pedal state and send one of two notes for open/closed hihiat.
d) bypass all other events to output
e) all events are passed to virtual output/another channel
f) a drum app can use that channel as input.

midi mapper apps exist for ios but as far as I know they are stateless and therefore they don’t work for that situation.


The Midiflow app supports conditions, so it could change the remapping of the hihat MIDI signal of the stick based on the foot controller‘s current position. However, the foot cotroller would have to send a CC based on the angle, for example: 127 for down and 0 for up. It does not do that from what I see in the MIDI monitor. Second, you would have to find a way to make GarageBand ignore the original MIDI data and only receive the modified one.


I finally found a way to make this (kind of work) on ios.

with the new version of the ios app “midifire” I achieved the following.

Each time I hit the hi hat pedal (foot turned to the left and pressed down) the hihat will alternate between open/closed hi hat sound.
I.e. the closed hi hat (wrist not turned) will be transformed into open or closed sound/midi note.

It works for music apps where you can select the output of midifire as midi Input.

For Garage Band there’s a problem as it will also get the original event from the sensor. Garage band overlays the different sounds. Probably it is possible to implement a workaround for that problem. Through midi configure the midi notes that are sent by the sensors. hihat should use a note that isn’t played by garageband. midi fire could map that note to open/closed hihat. Anyway: I didn’t do this as it’s rather complex.

I’ve attached the midifire configuration which can be loaded into midifire as a scene.
You need to connect your sensors in midifire (Setup/Connect Device), events will be routed to the midifire output channel.
I’m not the developer of midifre but I think it’s a mighty tool as it allows any kind of midi manipulation through programming.

Scene-hihatswitcher.mfr (2.9 KB)


It is now available in our Freedrum app for iOS and MacOS. Coming to Android end of Q2 2018. :slight_smile:


My hi-hat no longer opens with the foot sensor. Yesterday, the hi-hat opened and closed with the foot sensor, but now I can only play the closed hi-hat sound with the foot sensor. Twisting with the hand sensor, and everything else continue to work properly.

The only change between yesterday and today is that my iPhone 6S and SE both updated to iOS 11.2.5


Hello Jimmy,

Try disconnecting and connecting the foot sensor again. If that doesn’t work go into the settings for that foot sensor and turn the foot sensor toggle off and on twice.

It should resend the information to the sensor and correct it.


yeah, that worked, thanks.