Steps To Fix Sensor Update Failed / Timeout


When you try to update the sensor, there is a rare case where the sensor does not respond to the request to update.

You will see an error in the Sensorware application and the LED on the sensor itself will turn red and becomes unresponsive.

This can be easily solved by following these steps:

  1. Hold down on the button of the sensor for 7 seconds until the LED blinks off and on (hard reset)
  2. You should see the sensor pulsing blue
  3. Close and reopen the Sensorware app
  4. Connect to the sensor and try to update it once more

That should ensure the update continues as normal. Repeat these steps again if you see the issue re-occur.


I managed to get passed step 1… of course but the LED won’t pulse blue. It stays always red and the sensor is as you said unresponsive. It keeps saying “DFU device disconnected” or “GATT ERROR”. All my sensors are still v3 and I have tried for 2 hours to get it to v6…


Now I tried it with another phone and it worked. Still sad that my regular phone didn’t get it done


Hello Gidnoot,

What phone were you using originally that didnt work?

Also, what phone did you use to get it to work?

Thank you.


Hello everyone,

I am having trouble with one of my sensors:

Impossible to turn it off: it keeps on with the blue light
Impossible to hard reset it: if i presse the button during 7 seconds, Nothing happens
It cannot be connected. It is not detected

What Can i do ? :frowning:

Thanks in advance,