Turn On/Off Twist Open HighHat Feature


Hey guys,

So I have the full set of 4 (double bass and both sticks for the hand). I find it frustrating when I dedicate my left foot for open and close HiHat but still accidentally hit the open HiHat on my left hand with the twist feature. I wish there was a way to turn it off. Thanks!


Hey Matthew,

Thanks for the feedback. This is something that has been brought up and we have in our roadmap. We want to turn off all twist gestures so you can play freely. Thanks again and keep rocking!


+1 I was going to ask for that as well. Thank you for including this in your roadmap.


Yes, looking forward for that new functionality !!


Works great! also love the ride twist, and used to love the rimshot on the snare(when twisting) but it stopped working after my last update.

Any idea how I could get it back? on Android.



We have noticed that restarting the app/device and resending the configuration can fix that.

When you are back in the app after restarting everything you need to just remove the snare and add it again.

Let us know if you need any further assistance.



I tried to remove/re-add the snare and then lost my drum configuration, then added/removed the snare again and when I came back in the app(after closing it) the lower row toms had moved and snare disappeared so I had to re-add it again… then the configuration stayed.

That said, in SENSORWARE I hear the rimshot sound when I twist over the snare part of the ‘air drum’ :slight_smile:

Just not hearing it when in the Freedrum app.

Also, just found out after couple updates I now am unable to change foot or stick on Android, trying on pc later tonight.

Can’t say the number of hours I put in this as I want this to work so much :stuck_out_tongue:

THank you ofr the reply, much appreciated.


Hey Chris,

We are aware of an issue with the configuration not saving when closing and reopening the app.

Can you give us details about the configuration issue you had on Android?


Had multiple issues(also had tons of fun before that just fyi;)
Right now my problem is that the 4 sensors are sticks.

and even if they work fine in the Freedrum app it is not allowing me to change foot/stick setting in the Freedrum 'Sensor configuration window.


All four are detected as v9 in sensorware and I can update 3 of them easily while the 4th I often have to put it in ‘yellow’ mode(hold 7 seconds from ‘off’ state)

Edit: One sensor also make sensorware say "can’t write to sensor’ and another one sometimes ‘Gatt error’(not always).

It worked fine for some weeks though… until I reseted my phone to factory(Umidigi A5 4gb ram w/Android 9 up-to-date)

With all that said, before I give up(if I ever do;), I will try one more thing. I think I had it working fine thd first time because I connected the sensors to my RG8 pc and used them in Reaper.

Is it possible that the fact I linked them to ‘Sensorware for win64’ and used them on the pc is the reason they finally worked fine on Android?

Thank you

Firmware question FD1 V9 vs FD2 V9

Once they are updated you do not have to update them again.

We know with Android it can be very tricky because of the sheer amount of different devices.

We can’t say for sure, but moving from one device to another could be the reason. Why are you unable to set it as a foot sensor. Is it because the devices don’t appear in the Freedrum app or you don’t have an option to select. Can you send a screenshot here?


Sure, here it is.

This morning, they shows different of yesterday but still have 4 sticks. 2 out of 4 show the option to switch from stick to foot but even if I check the box it doesn’t change… still 4 sticks.

Edit #2: also just FYI at some point FD1 becomes FD2V9

Edit: here are the screenshots:

Edit #3 @Seyran I just closed all sensors after disconnecting them, restarted the phone and tried again and now I have different results in the Freedrum app, **you can see 1 out of 4 now is ‘FD21 V9’ and I didn’t do any update I just restarted the phone… There are the new screenshots:

EDIT #4 : Connected to PC and with Sensorware on Win10 64bits and now I have 2 sticks and two pedals which is perfect for me, but only 6 ‘zones’ I think(not sure I understand fully how those work yet) because I sent the foot configuration through sensorware.

Now it works in Reaper, i’m a bit scared to go back to Android :blush:

Edity #5 some screenshots of what I say in Edit #4 :slight_smile:

At least I can play :o) Thanks a lot @Seyran for your help

Edit #6: @Seyran finally plugged with bluetooth on my RG8 with sensorware for win64, connected to reaper/configured buffer so it doesnt lag at low latencies, and now everything, I mean it ALL works so fine :smiley:

I don’t know why but will leave like that for now and try again Android when I see updates eventually :o)

If you have any tips on how I could make it work fine on Android it would be appreciated a lot of course, since i’d like to try it in my car next :wink: lol

Have a good day

P.S. I started documenting and will eventually a bit later publish a ‘Cheatsheet’ for people having issues, so they could browse throught that if stuck in the future.

Just FYI for it to work fine on Windows 10 I think the thing that influenced the most on my side was to make sure I have the best bluetooth drivers for my computer, which I didn’t have from the start.

Thank you


Hey! This is great thank you for putting in the work to explain in such detail. We will add it to the ticketing system as well as work to put up a specific page on our website.

We have not seen this specific issue where you dont see the settings for the sensors in the app. One thing that we just realized is that we didn’t ask if the version of the app you are using is the beta version.

You can see it in the play store. That is the only thing I could think of at the moment that would still cause this issue.


Hey @Seyran,

I did activate ‘alpha features’ in sensorware on android(it is an option in the dropdown menu), but when I began having troubles I deactivated this.

I just checked in the play store, under ‘My apps and games’ and then in the ‘Beta’ tab, Freedrum is not listed there so I think this means I did not opt in the beta, correct?

Edit: oh and guess what? I have the rimshot now(in windows with reaper and a vst plugin) :)) very happy about that one. LoL :scream:

Thank you again for the help! much appreciated.