Windows Support


#62

I’m not sure if this will work but I found a usb-bluetooth adapter which is recognized as midi device.
It’s called “widi bud” and according to the description it should work even with win7 etc. as no special driver is needed. Unfortunately it’s rather expensive when compared to a normal bluetooth dongle.

As I don’t own such a dongle I can’t test it.

One comment on amazon.com says: you can only connect one device at a time. I.e. maybe you need four of these to connect 4 sensors. In that case this wouldn’t be a viable solution.


#63

Thanks for this idea, it’s quite expensive but maybe there’s a cheaper alternative, I’ll search !

=> I’m afraid that you have to use 4 widi buds for 4 sensors, better buy a used Iphone 4S in this case :confused:


#64

Still no news about how to rename sensors ? It would be really cool


#65

It’s being worked on. Renaming will most likely be coming in Q1 2018.


#67

So, I have been a longtime CakeWalk / Sonar user, but with them announcing no more development, I have been looking at alternatives. It didn’t take me long to settle on PreSonus Studio One 3 as the most likely candidate, and I have downloaded the demo version (fully functioning for 30 days) before making a decision.

Runs on both my Mac and Win 10 machines. I thought I would try the freedoms on windows 10 today. I’m using the ASUS bluetooth dongle, and have updated the sticks to v7. Reset my windows bluetooth devices and connected all four sticks. Opened StudioOne. Went to Options, External Devices, and selected Add New Keyboard. Each of the sticks showed as FreeDrum, FreeDrum (2), FreeDrum (3) and FreeDrum (4). Added a new keyboard using each of those inputs so I now have four freedrum midi devices.

Loaded MT PowerDrums instrument. Set input to ALL. Armed the track for RECORD, and all working well. All four sensors operating at the same time, foot and stick doing what they are supposed to. Couldn’t actually get this to work in Sonar since it couldn’t cope with the sensors all having the same name - I could only get one to work at a time.

I also then loaded multiple copies of session drummer as an instrument as well. Set the inputs to each instrument to each of the freedrum senors, and all worked great. So each stick/foot can have its own instrument, and hence different sounds, all playing and recording simultaneously.

So a big thumbs up for StudioOne and all four sticks working fine with no need for renaming in the firmware. So far everything I have tried has worked well. Looks like I’ll be moving over from Sonar.

Haven’t tried the FreeDrums on StudioOne on my Mac yet, but can’t see why that wouldn’t work as well.


#69

Using an ASUS BT-400, installed the Korg BLE driver, can get the sensors to work OK in FL Studio and Ableton Live. However, while using one stick is OK, it doesn’t deal will with two sticks hitting at the same time and there is a delay on one of the hits. This basically makes them unusable - has anyone experienced this/has a solution?

When using Freedrum with an iPad or other mobile device and headphones, the experience is very good, however using these to record with good sample libraries + DAW was a big motivation behind purchase.


#70

Hello there ! (i’m french so i apologize if my english is too bad)
I follow those steps :

  • I instal the free version of “Reaper” on the official website
  • I instal “nanoKey Studio” (link up) / i don’t know if is effective in my case
  • I instal “MT Power Drumkit 2”, a VSTi plugin that work whith “Reaper”
  • I learn how to instal and configure midi for theses softwares in 3 videos :
    - first (instal VST plugin) : https://www.youtube.com/watch?v=qroQI3qMzc4
    - second (configure MIDI) : https://www.youtube.com/watch?v=QV9WkY4Zy_I
    - third (select a plugin) : the video after in suggestions (I’m new in this channel so I can only post 2 links sorry)
    of course you have to select “MT P. Drumkit 2” in the plugins list and repeat this for all four freedrum sensors
    and just appreciate :slight_smile:
    but just one thing, I try this on my laptop (ASUS zenbook plus UX430) and when I hit more than one stick (or one sensor in general) the latency badly increase… I think it’s Windows + bluetooth (it’s actualy Bluetooth 4.1 so idk)
    Thx for the comments and enjoy !
    PS: I have FL Studio set up on another computer (a beast gaming pc) and I will try it

#71

I’ve followed all of the steps for setting up reaper on windows 10 and none of the sensors show up under midi devices. Does anyone know why? I’ve reinstalled KORG drivers a ton of times, Ive removed them from bluetooth and readded and still nothing. Very aggravating and I’m not sure how to make it work. I’ve tried Internal and external bluetooth(adapter) as well. Still nothing.


#72

Is that all the sensors are associated with the computer in bluetooth settings?
Have you enabled all the sensors in the midi settings in Reaper?
Have you instaled the drum plugin?


#73

I can’t seem to get the sensors to show up in reaper as midi devices. I don’t think the KORG driver is working.


#74

For the lag I fixed it switching the audio system from “Wave Out” to “ASIO”, of course ^^


#75

I just test it in a macbook pro 2017 with Grageband, and OMFG is just awesome!